Browse Source

Release v1.1

main 1.1
Vítězslav Dvořák 2 years ago
parent
commit
8ca159c923
  1. 6
      Makefile
  2. 2
      composer.json
  3. 12
      debian/changelog
  4. 4
      debian/composer.json
  5. 27
      debian/control
  6. 6
      debian/files
  7. 5
      debian/fixversion.sh
  8. 4
      debian/php-ease-bootstrap4-doc.conf
  9. 4
      debian/php-ease-bootstrap4-doc.install
  10. 2
      debian/php-ease-bootstrap4.install
  11. 47
      debian/php-ease-bootstrap4.postinst
  12. 9
      debian/rules

6
Makefile

@ -27,10 +27,10 @@ fresh:
clean:
rm -rf vendor composer.lock
rm -rf debian/php-ease-bootstrap
rm -rf debian/php-ease-bootstrap-doc
rm -rf debian/php-vitexsoftware-ease-bootstrap4
rm -rf debian/php-vitexsoftware-ease-bootstrap4-doc
rm -rf debian/*.log debian/tmp
rm -rf docs/*
rm -rf .phpdoc/*
apigen:
VERSION=`cat debian/composer.json | grep version | awk -F'"' '{print $4}'`; \

2
composer.json

@ -10,7 +10,7 @@
}
],
"require": {
"vitexsoftware/ease-html": ">= 1.23"
"vitexsoftware/ease-html": ">= 1.25"
},
"autoload": {
"psr-4": {

12
debian/changelog vendored

@ -1,23 +1,17 @@
php-ease-bootstrap4 (0.7.5) UNRELEASED; urgency=medium
php-vitexsoftware-ease-bootstrap4 (1.1) UNRELEASED; urgency=medium
[ Vítězslav Dvořák ]
* First release
* Label extend
* Label extend
* Tabs OK now
[ CyberVitexus ]
* composer-global-update fix
* enable javascript-common
* Merge branch 'master' of github.com:VitexSoftware/ease-twbootstrap4
* Merge branch 'master' of github.com:VitexSoftware/ease-twbootstrap4
* Merge branch 'master' of github.com:VitexSoftware/ease-twbootstrap4
* Merge branch 'master' of github.com:VitexSoftware/ease-twbootstrap4
* Merge branch 'master' of github.com:VitexSoftware/ease-twbootstrap4
* Merge branch 'master' of github.com:VitexSoftware/ease-twbootstrap4
* Merge branch 'master' of github.com:VitexSoftware/ease-twbootstrap4
* Debian package renamed
* Debian package workflow
* Allow submenu to be place on right side
* v1.0 release
-- CyberVitexus <vitex@exiv.jinonice.czf> Sun, 16 Aug 2020 11:07:32 +0200
-- CyberVitexus <vitex@exiv.jinonice.czf> Fri, 16 Oct 2020 01:13:03 +0200

4
debian/composer.json vendored

@ -1,7 +1,7 @@
{
"name": "deb/ease-bootstrap4",
"description": "Set of Twitter Bootstrap 4 rendering objects (debianized)",
"version": "0.1",
"version": "1.1",
"authors": [
{
"name": "Vítězslav Dvořák",
@ -31,5 +31,5 @@
"type": "library",
"homepage": "http://v.s.cz/ease.php",
"license": "GPL-2.0+",
"address": "0.7.5"
"address": "1.0"
}

27
debian/control vendored

@ -1,5 +1,5 @@
Source: php-ease-bootstrap4
Build-Depends: debhelper (>= 7.0.50~), jq, moreutils
Source: php-vitexsoftware-ease-bootstrap4
Build-Depends: debhelper (>= 7.0.50~), jq, moreutils, phpdocumentor
Section: web
Standards-Version: 3.9.8
Maintainer: Vítězslav Dvořák <info@vitexsoftware.cz>
@ -7,7 +7,7 @@ Uploaders: Vitex <vitex@hippy.cz>
Priority: optional
Homepage: https://github.com/VitexSoftware/ease-bootstrap4
Package: php-ease-bootstrap4
Package: php-vitexsoftware-ease-bootstrap4
Depends: ${misc:Depends},php-ease-html,javascript-common
Architecture: all
Conflicts: ease-framework
@ -16,3 +16,24 @@ Section: web
Priority: optional
Description: Set of Twitter Bootstrap 4 rendering objects
TWB4 classes for Ease Framework.
Package: php-vitexsoftware-ease-bootstrap4-dev
Depends: ${misc:Depends}, php-vitexsoftware-ease-bootstrap4
Architecture: all
Replaces: php-ease-bootstrap4-dev
Suggests: php-vitexsoftware-ease-html
Section: web
Priority: optional
Description: EasePHP Framework Unit Tests
Ease Framework Core unit Test classes.
Package: php-vitexsoftware-ease-bootstrap4-doc
Depends: ${misc:Depends}, php-vitexsoftware-ease-bootstrap4-dev
Architecture: all
Conflicts: ease-framework-doc
Section: devel
Priority: optional
Description: EasePHP Framework HTML unit documentation
HTML classes for Ease Framework documentation generated by apigen

6
debian/files vendored

@ -1,2 +1,4 @@
php-ease-bootstrap4_0.7.5_all.deb web optional
php-ease-bootstrap4_0.7.5_amd64.buildinfo web optional
php-vitexsoftware-ease-bootstrap4-dev_1.1_all.deb web optional
php-vitexsoftware-ease-bootstrap4-doc_1.1_all.deb devel optional
php-vitexsoftware-ease-bootstrap4_1.1_all.deb web optional
php-vitexsoftware-ease-bootstrap4_1.1_amd64.buildinfo web optional

5
debian/fixversion.sh vendored

@ -1,5 +0,0 @@
#!/bin/bash
VERSTR=`dpkg-parsechangelog --show-field Version`
COMPOSER_VERSTR=`echo ${VERSTR}|sed 's/-/./g'`
echo update debian/php-ease-bootstrap/usr/share/php/EaseTWB/composer.json version to ${COMPOSER_VERSTR}
sed -i -e '/\"version\"/c\ \"version\": \"'${COMPOSER_VERSTR}'",' debian/php-ease-html/usr/share/php/EaseTWB/composer.json

4
debian/php-ease-bootstrap4-doc.conf vendored

@ -1,4 +0,0 @@
Alias /ease-core /usr/share/doc/ease-core/html
Alias /EasePHPFramework /usr/share/doc/ease-core/html

4
debian/php-ease-bootstrap4-doc.install vendored

@ -1,4 +0,0 @@
docs/* usr/share/doc/ease-html/html
docs/resources/* usr/share/doc/ease-html/html/resources
debian/ease-html-doc.conf usr/share/doc/ease-html-doc/apache
README.md usr/share/doc/ease-html

2
debian/php-ease-bootstrap4.install vendored

@ -1,2 +0,0 @@
src/Ease/TWB4/* usr/share/php/EaseTWB4/
debian/composer.json usr/share/php/EaseTWB4/

47
debian/php-ease-bootstrap4.postinst vendored

@ -1,47 +0,0 @@
#!/bin/sh
#DEBHELPER#
# postinst script for php-ease-bootstrap4
#
# see: dh_installdeb(1)
set -e
# summary of how this script can be called:
# * <postinst> `configure' <most-recently-configured-version>
# * <old-postinst> `abort-upgrade' <new version>
# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
# <new-version>
# * <postinst> `abort-remove'
# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
# <failed-install-package> <version> `removing'
# <conflicting-package> <version>
# for details, see http://www.debian.org/doc/debian-policy/ or
# the debian-policy package
case "$1" in
configure)
composer-global-update deb/ease-bootstrap4
if [ -f /usr/sbin/a2enconf ]; then
a2enconf javascript-common
fi
;;
abort-upgrade|abort-remove|abort-deconfigure)
;;
*)
echo "postinst called with unknown argument \`$1'" >&2
exit 1
;;
esac
# dh_installdeb will replace this with shell code automatically
# generated by other debhelper scripts.
exit 0
#DEBHELPER#

9
debian/rules vendored

@ -6,9 +6,16 @@ BUILD_DIR:=build
%:
dh $@
override_dh_prep:
rm docs/* -rf
phpdoc -d src --title "Vitex Software's Ease Twitter Bootstrap4"
mv .phpdoc/build/* docs
dh_prep
override_dh_auto_test:
echo tests temporarly skipped for now in rules file
override_dh_install:
jq '.address = "'`dpkg-parsechangelog | sed -n 's/^Version: //p'`'"' debian/composer.json |sponge debian/composer.json
jq '.version = "'`dpkg-parsechangelog | sed -n 's/^Version: //p'`'"' debian/composer.json |sponge debian/composer.json
dh_install

Loading…
Cancel
Save